summaryrefslogtreecommitdiffstats
path: root/gst/videofilter/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2005-05-11 16:38:30 +0000
committerTim-Philipp Müller <tim@centricular.net>2005-05-11 16:38:30 +0000
commit4ca8c41b448f9a48366fbff28a155f6989a1f079 (patch)
tree74dd45eb8eb9902d2dbc4880949231e927f696cc /gst/videofilter/Makefile.am
parent63177e073100ce81a14338c464bb1cb83c27c3a7 (diff)
gst/: Turn videofilter into a library (private for now)
Original commit message from CVS: * gst/effectv/Makefile.am: * gst/videofilter/Makefile.am: Turn videofilter into a library (private for now)
Diffstat (limited to 'gst/videofilter/Makefile.am')
-rw-r--r--gst/videofilter/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/gst/videofilter/Makefile.am b/gst/videofilter/Makefile.am
index 9171d5b1..d24b3b3b 100644
--- a/gst/videofilter/Makefile.am
+++ b/gst/videofilter/Makefile.am
@@ -1,5 +1,5 @@
-plugin_LTLIBRARIES = libgstvideofilter.la
+lib_LTLIBRARIES = libgstvideofilter-@GST_MAJORMINOR@.la
noinst_LTLIBRARIES = libgstvideoexample.la
noinst_HEADERS = gstvideofilter.h
@@ -7,10 +7,9 @@ noinst_HEADERS = gstvideofilter.h
EXTRA_DIST = gstvideotemplate.c make_filter
CLEANFILES = gstvideoexample.c
-libgstvideofilter_la_SOURCES = gstvideofilter.c
-libgstvideofilter_la_CFLAGS = $(GST_CFLAGS)
-libgstvideofilter_la_LIBADD =
-libgstvideofilter_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstvideofilter_@GST_MAJORMINOR@_la_SOURCES = gstvideofilter.c gstvideofilter.h
+libgstvideofilter_@GST_MAJORMINOR@_la_CFLAGS = $(GST_CFLAGS)
+libgstvideofilter_@GST_MAJORMINOR@_la_LDFLAGS = $(GST_LIBS)
libgstvideoexample_la_SOURCES = gstvideoexample.c
libgstvideoexample_la_CFLAGS = $(GST_CFLAGS)