summaryrefslogtreecommitdiffstats
path: root/gst/videofilter/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2004-01-07 21:36:52 +0000
committerDavid Schleef <ds@schleef.org>2004-01-07 21:36:52 +0000
commit60f5f23055e7b26903209cada31aa507844ec0ab (patch)
tree8c693bd951cced2f11687dccf08d35d1914c52af /gst/videofilter/Makefile.am
parent6f0026286d24e2134681248d2e313934d0b4782f (diff)
Handle builddir != srcdir builds with making gstvideoexample.c
Original commit message from CVS: Handle builddir != srcdir builds with making gstvideoexample.c
Diffstat (limited to 'gst/videofilter/Makefile.am')
-rw-r--r--gst/videofilter/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/gst/videofilter/Makefile.am b/gst/videofilter/Makefile.am
index 8b90a94f..56e54c98 100644
--- a/gst/videofilter/Makefile.am
+++ b/gst/videofilter/Makefile.am
@@ -6,7 +6,7 @@ noinst_LTLIBRARIES = libgstvideoexample.la
noinst_HEADERS = gstvideofilter.h gstvideoflip.h gstvideobalance.h
EXTRA_DIST = gstvideotemplate.c make_filter
-EXTRA_CLEAN = gstvideoexample.c
+CLEANFILES = gstvideoexample.c
libgstvideofilter_la_SOURCES = gstvideofilter.c
libgstvideofilter_la_CFLAGS = $(GST_CFLAGS)
@@ -29,7 +29,6 @@ libgstvideobalance_la_LIBADD =
libgstvideobalance_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -lm
-# no, this doesn't work if $(srcdir) != (builddir)
gstvideoexample.c: $(srcdir)/make_filter $(srcdir)/gstvideotemplate.c
- $(srcdir)/make_filter Videoexample
+ $(srcdir)/make_filter Videoexample $(srcdir)/gstvideotemplate.c