summaryrefslogtreecommitdiffstats
path: root/gst/videofilter/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2003-07-02 06:49:37 +0000
committerDavid Schleef <ds@schleef.org>2003-07-02 06:49:37 +0000
commitc6e986c8e4580ac3f72964104a516f7c9b992ba2 (patch)
treecafda217893dc67376bc1f5b08f5614f803394ab /gst/videofilter/Makefile.am
parent623f55f1949bd83b9f026fe2fa70309641227e9b (diff)
video balancing (brightness, contrast, etc.)
Original commit message from CVS: video balancing (brightness, contrast, etc.)
Diffstat (limited to 'gst/videofilter/Makefile.am')
-rw-r--r--gst/videofilter/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/gst/videofilter/Makefile.am b/gst/videofilter/Makefile.am
index e6c4c9ea..75cf2b86 100644
--- a/gst/videofilter/Makefile.am
+++ b/gst/videofilter/Makefile.am
@@ -1,6 +1,7 @@
plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
-plugin_LTLIBRARIES = libgstvideofilter.la libgstvideoflip.la
+plugin_LTLIBRARIES = libgstvideofilter.la libgstvideoflip.la \
+ libgstvideobalance.la
noinst_LTLIBRARIES = libgstvideoexample.la
noinst_HEADERS = gstvideofilter.h gstvideoexample.h gstvideoflip.h
@@ -23,6 +24,11 @@ libgstvideoflip_la_CFLAGS = $(GST_CFLAGS)
libgstvideoflip_la_LIBADD =
libgstvideoflip_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstvideobalance_la_SOURCES = gstvideobalance.c
+libgstvideobalance_la_CFLAGS = $(GST_CFLAGS)
+libgstvideobalance_la_LIBADD =
+libgstvideobalance_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -lm
+
# no, this doesn't work if $(srcdir) != (builddir)
gstvideoexample.c gstvideoexample.h: $(srcdir)/make_filter \