summaryrefslogtreecommitdiffstats
path: root/pkgconfig/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2006-04-03 09:02:29 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2006-04-03 09:02:29 +0000
commit12b60c256b95944184a7b2415e7e63976f648ec8 (patch)
tree232a4061516725d4f16bdd30a725c38ccdf2aa1c /pkgconfig/Makefile.am
parent56640c96217908a9062295fbe5e5ba8630b68bb3 (diff)
add a .pc file so other modules can use good plugins in tests
Original commit message from CVS: * Makefile.am: * configure.ac: * pkgconfig/.cvsignore: * pkgconfig/Makefile.am: * pkgconfig/gstreamer-plugins-good-uninstalled.pc.in: add a .pc file so other modules can use good plugins in tests
Diffstat (limited to 'pkgconfig/Makefile.am')
-rw-r--r--pkgconfig/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
new file mode 100644
index 00000000..0b183655
--- /dev/null
+++ b/pkgconfig/Makefile.am
@@ -0,0 +1,25 @@
+### all of the standard pc files we need to generate
+pcverfiles = \
+ gstreamer-plugins-good-@GST_MAJORMINOR@.pc
+pcverfiles_uninstalled = \
+ gstreamer-plugins-good-@GST_MAJORMINOR@-uninstalled.pc
+
+### all-local: $(pcverfiles) $(pcverfiles_uninstalled)
+all-local: $(pcverfiles_uninstalled)
+
+### how to generate versioned .pc files from .pc files in this dir
+%-@GST_MAJORMINOR@.pc: %.pc
+ cp $< $@
+%-@GST_MAJORMINOR@-uninstalled.pc: %-uninstalled.pc
+ cp $< $@
+
+# do not install for now
+# pkgconfigdir = $(libdir)/pkgconfig
+# pkgconfig_DATA = $(pcverfiles)
+
+CLEANFILES = $(pcverfiles) $(pcverfiles_uninstalled)
+pcinfiles = \
+ gstreamer-plugins-good.pc.in gstreamer-plugins-good-uninstalled.pc.in
+
+DISTCLEANFILES = $(pcinfiles:.in=)
+EXTRA_DIST = $(pcinfiles)