summaryrefslogtreecommitdiffstats
path: root/sys/v4l2/Makefile.am
diff options
context:
space:
mode:
authorRob Clark <rob@ti.com>2009-08-04 09:14:20 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2009-08-04 09:16:56 +0200
commitf19cfbda96d098362cc2a2565197cef347878549 (patch)
tree598fdc98292aa14467da24fd6d711590588c1f68 /sys/v4l2/Makefile.am
parent56850099a6a47b8c3f8606f8107d42cb86dfe601 (diff)
v4l2: Add v4l2sink element
This also does the following changes: (1) pull the bufferpool code out into gstv4l2bufferpool.c, and make a bit more generic so it can be used both for v4l2src and v4l2sink (2) move some of the device probing/configuration/caps stuff into gstv4l2object.c so it does not have to be duplicated between v4l2src and v4l2sink Fixes bug #590280.
Diffstat (limited to 'sys/v4l2/Makefile.am')
-rw-r--r--sys/v4l2/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/sys/v4l2/Makefile.am b/sys/v4l2/Makefile.am
index 20ec5486..cf972cc2 100644
--- a/sys/v4l2/Makefile.am
+++ b/sys/v4l2/Makefile.am
@@ -12,7 +12,9 @@ plugin_LTLIBRARIES = libgstvideo4linux2.la
libgstvideo4linux2_la_SOURCES = gstv4l2.c \
gstv4l2colorbalance.c \
gstv4l2object.c \
+ gstv4l2bufferpool.c \
gstv4l2src.c \
+ gstv4l2sink.c \
gstv4l2tuner.c \
gstv4l2vidorient.c \
v4l2_calls.c \
@@ -31,6 +33,7 @@ libgstvideo4linux2_la_LIBTOOLFLAGS = --tag=disable-static
libgstvideo4linux2_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) \
$(GST_BASE_LIBS) \
+ $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_MAJORMINOR) \
-lgstinterfaces-$(GST_MAJORMINOR) \
$(GST_LIBS) \
$(xv_libs) \