summaryrefslogtreecommitdiffstats
path: root/tests/icles/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2008-11-25 16:06:22 +0000
committerWim Taymans <wim.taymans@gmail.com>2008-11-25 16:06:22 +0000
commit6ab4698b95bed4ca4032b791d84f26fd2e11224a (patch)
treebdfae8fc836e1cfad539e03200f9baef55411483 /tests/icles/Makefile.am
parent0b5fea8568e6e66485e1c3aeff03bf402c1427d1 (diff)
gst/videocrop/gstvideocrop.*: Fix renegotiation when changing properties using the new basetransform features. Fixes ...
Original commit message from CVS: * gst/videocrop/gstvideocrop.c: (gst_video_crop_init), (gst_video_crop_transform), (gst_video_crop_transform_caps), (gst_video_crop_set_caps), (gst_video_crop_set_property): * gst/videocrop/gstvideocrop.h: Fix renegotiation when changing properties using the new basetransform features. Fixes #561502. * tests/icles/Makefile.am: * tests/icles/videocrop2-test.c: (make_pipeline), (main): Add crazy interactive test unit for dynamically changing properties.
Diffstat (limited to 'tests/icles/Makefile.am')
-rw-r--r--tests/icles/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/icles/Makefile.am b/tests/icles/Makefile.am
index 0f545ce4..3cacdd1e 100644
--- a/tests/icles/Makefile.am
+++ b/tests/icles/Makefile.am
@@ -40,5 +40,10 @@ videobox_test_CFLAGS = $(GST_CFLAGS)
videobox_test_LDADD = $(GST_LIBS)
videobox_test_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_PROGRAMS = $(GTK_TESTS) $(V4L2_TESTS) $(X_TESTS) videocrop-test videobox-test
+videocrop2_test_SOURCES = videocrop2-test.c
+videocrop2_test_CFLAGS = $(GST_CFLAGS)
+videocrop2_test_LDADD = $(GST_LIBS)
+videocrop2_test_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_PROGRAMS = $(GTK_TESTS) $(V4L2_TESTS) $(X_TESTS) videocrop-test videobox-test videocrop2-test