summaryrefslogtreecommitdiffstats
path: root/docs/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/plugins/Makefile.am')
-rw-r--r--docs/plugins/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/docs/plugins/Makefile.am b/docs/plugins/Makefile.am
index 936e4e2d..640edbbb 100644
--- a/docs/plugins/Makefile.am
+++ b/docs/plugins/Makefile.am
@@ -48,8 +48,11 @@ SCAN_OPTIONS=
MKDB_OPTIONS=--sgml-mode --source-suffixes=c,h,cc
# Extra options to supply to gtkdoc-fixref.
-# FIXME get the location of the installed gstreamer docs
-#FIXXREF_OPTIONS=--extra-dir=../gst/html
+FIXXREF_OPTIONS=--extra-dir=$(GLIB_PREFIX)/share/gtk-doc/html/gobject \
+ --extra-dir=$(GLIB_PREFIX)/share/gtk-doc/html/glib \
+ --extra-dir=$(GST_PREFIX)/share/gtk-doc/html/gstreamer-@GST_MAJORMINOR@ \
+ --extra-dir=$(GST_PREFIX)/share/gtk-doc/html/gstreamer-libs-@GST_MAJORMINOR@ \
+ --extra-dir=$(GSTPB_PREFIX)/share/gtk-doc/html/gst-plugins-base-libs-@GST_MAJORMINOR@
# Used for dependencies.
HFILE_GLOB=$(DOC_SOURCE_DIR)/*/*/*.h