summaryrefslogtreecommitdiffstats
path: root/ext/gdk_pixbuf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/gdk_pixbuf/Makefile.am')
-rw-r--r--ext/gdk_pixbuf/Makefile.am34
1 files changed, 7 insertions, 27 deletions
diff --git a/ext/gdk_pixbuf/Makefile.am b/ext/gdk_pixbuf/Makefile.am
index 0f6a6c9a..316ca4e5 100644
--- a/ext/gdk_pixbuf/Makefile.am
+++ b/ext/gdk_pixbuf/Makefile.am
@@ -1,34 +1,14 @@
plugin_LTLIBRARIES = libgstgdkpixbuf.la
libgstgdkpixbuf_la_SOURCES = gstgdkpixbuf.c pixbufscale.c
-libgstgdkpixbuf_la_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS) $(GST_BASE_CFLAGS) \
- $(GST_PLUGINS_BASE_CFLAGS)
-libgstgdkpixbuf_la_LIBADD = $(GTK_LIBS) $(GST_LIBS) $(GST_BASE_LIBS)
+libgstgdkpixbuf_la_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS) $(GTK_CFLAGS)
+libgstgdkpixbuf_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(GTK_LIBS)
libgstgdkpixbuf_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-
-#if
-#loaderdir = $(DESTDIR)$(GDK_PIXBUF_LOADER_DIR)
-#loader_LTLIBRARIES = gst_loader.la
-#
-#install-data-hook:
-# if test -z "$(DESTDIR)" ; then \
-# $(mkinstalldirs) $(DESTDIR)$(GDK_PIXBUF_CONF_DIR) ; \
-# $(QUERYLOADERS) > $(DESTDIR)$(GDK_PIXBUF_CONF_DIR)/gdk-pixbuf.loaders ; \
-# fi
-#
-#gst_loader_la_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS) -DGDK_PIXBUF_ENABLE_BACKEND
-#gst_loader_la_SOURCES = \
-# gstgdkanimation.c \
-# gst_loader.c
-#gst_loader_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) --avoid-version --module
-#gst_loader_la_LIBADD = $(GTK_LIBS) $(GST_LIBS)
-#else
-install-data-hook:
- true
-#endif
-
-noinst_HEADERS = gstgdkpixbuf.h \
+noinst_HEADERS = \
+ gstgdkpixbuf.h \
pixbufscale.h \
gstgdkanimation.h
-