summaryrefslogtreecommitdiffstats
path: root/gst/equalizer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/equalizer/Makefile.am')
-rw-r--r--gst/equalizer/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/gst/equalizer/Makefile.am b/gst/equalizer/Makefile.am
index d85bc5a4..ed26e295 100644
--- a/gst/equalizer/Makefile.am
+++ b/gst/equalizer/Makefile.am
@@ -1,6 +1,6 @@
plugin_LTLIBRARIES = libgstequalizer.la
libgstequalizer_la_SOURCES = gstiirequalizer.c
-libgstequalizer_la_CFLAGS = $(GST_CFLAGS)
-libgstequalizer_la_LIBADD =
-libgstequalizer_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -lm
+libgstequalizer_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstequalizer_la_LIBADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR)
+libgstequalizer_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)