summaryrefslogtreecommitdiffstats
path: root/gst/equalizer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/equalizer/Makefile.am')
-rw-r--r--gst/equalizer/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/gst/equalizer/Makefile.am b/gst/equalizer/Makefile.am
index 042f32c6..ceb6877d 100644
--- a/gst/equalizer/Makefile.am
+++ b/gst/equalizer/Makefile.am
@@ -11,3 +11,12 @@ libgstequalizer_la_LIBADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GS
libgstequalizer_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstiirequalizer.h
+
+if HAVE_GTK
+noinst_PROGRAMS = demo
+endif
+
+demo_SOURCES = demo.c
+demo_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(GTK_CFLAGS)
+demo_LDFLAGS = $(GST_BASE_LIBS) $(GST_LIBS) $(GTK_LIBS)
+