summaryrefslogtreecommitdiffstats
path: root/gst/replaygain/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/replaygain/Makefile.am')
-rw-r--r--gst/replaygain/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/gst/replaygain/Makefile.am b/gst/replaygain/Makefile.am
index d4523654..a0a3ca5a 100644
--- a/gst/replaygain/Makefile.am
+++ b/gst/replaygain/Makefile.am
@@ -2,12 +2,20 @@ plugin_LTLIBRARIES = libgstreplaygain.la
libgstreplaygain_la_SOURCES = \
gstrganalysis.c \
+ gstrglimiter.c \
+ gstrgvolume.c \
+ replaygain.c \
rganalysis.c
-libgstreplaygain_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS)
-libgstreplaygain_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(LIBM)
+libgstreplaygain_la_CFLAGS = \
+ $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstreplaygain_la_LIBADD = \
+ $(GST_LIBS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstpbutils-0.10 $(LIBM)
libgstreplaygain_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
# headers we need but don't want installed
noinst_HEADERS = \
gstrganalysis.h \
+ gstrglimiter.h \
+ gstrgvolume.h \
+ replaygain.h \
rganalysis.h