summaryrefslogtreecommitdiffstats
path: root/gst/videocrop/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/videocrop/Makefile.am')
-rw-r--r--gst/videocrop/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/gst/videocrop/Makefile.am b/gst/videocrop/Makefile.am
index 81c41990..6cf889aa 100644
--- a/gst/videocrop/Makefile.am
+++ b/gst/videocrop/Makefile.am
@@ -1,9 +1,12 @@
-
plugin_LTLIBRARIES = libgstvideocrop.la
+# Note: we only use defines from gst/video/video.h, but none
+# of the functions, so we don't need to link to libgstvideo
+
libgstvideocrop_la_SOURCES = gstvideocrop.c
-libgstvideocrop_la_CFLAGS = $(GST_CFLAGS)
-libgstvideocrop_la_LIBADD =
+libgstvideocrop_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) $(LIBOIL_CFLAGS)
+libgstvideocrop_la_LIBADD = $(GST_BASE_LIBS) $(LIBOIL_LIBS)
libgstvideocrop_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS =