summaryrefslogtreecommitdiffstats
path: root/gst/videofilter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/videofilter/Makefile.am')
-rw-r--r--gst/videofilter/Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/gst/videofilter/Makefile.am b/gst/videofilter/Makefile.am
index 3bfcbce6..cb5e286b 100644
--- a/gst/videofilter/Makefile.am
+++ b/gst/videofilter/Makefile.am
@@ -1,16 +1,11 @@
-noinst_LTLIBRARIES = libgstvideofilter-@GST_MAJORMINOR@.la
# noinst_LTLIBRARIES = libgstvideoexample.la
plugin_LTLIBRARIES = libgstvideoflip.la
-noinst_HEADERS = gstvideofilter.h gstvideoflip.h
+noinst_HEADERS = gstvideoflip.h
EXTRA_DIST = gstvideotemplate.c make_filter
CLEANFILES = gstvideoexample.c
-libgstvideofilter_@GST_MAJORMINOR@_la_SOURCES = gstvideofilter.c gstvideofilter.h
-libgstvideofilter_@GST_MAJORMINOR@_la_CFLAGS = $(GST_CFLAGS)
-libgstvideofilter_@GST_MAJORMINOR@_la_LIBS = $(GST_LIBS)
-
# libgstvideoexample_la_SOURCES = gstvideoexample.c
# libgstvideoexample_la_CFLAGS = $(GST_CFLAGS)
# libgstvideoexample_la_LIBADD = libgstvideofilter-@GST_MAJORMINOR@.la $(GST_LIBS)
@@ -19,8 +14,7 @@ libgstvideofilter_@GST_MAJORMINOR@_la_LIBS = $(GST_LIBS)
libgstvideoflip_la_SOURCES = gstvideoflip.c
libgstvideoflip_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
$(GST_PLUGINS_BASE_CFLAGS)
-libgstvideoflip_la_LIBADD = libgstvideofilter-@GST_MAJORMINOR@.la $(GST_LIBS) \
- $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS)
+libgstvideoflip_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstvideo-@GST_MAJORMINOR@ $(GST_BASE_LIBS) $(GST_LIBS)
libgstvideoflip_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
# libgstvideobalance_la_SOURCES = gstvideobalance.c