summaryrefslogtreecommitdiffstats
path: root/sys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index 160ec779..50028bc2 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -58,6 +58,12 @@ endif
# GL_DIR=
# endif
-SUBDIRS=$(OSS_DIR) $(SUNAUDIO_DIR)
+if USE_X
+XIMAGE_DIR=ximage
+else
+XIMAGE_DIR=
+endif
+
+SUBDIRS=$(OSS_DIR) $(SUNAUDIO_DIR) $(XIMAGE_DIR)
-DIST_SUBDIRS=oss sunaudio
+DIST_SUBDIRS=oss sunaudio ximage