summaryrefslogtreecommitdiffstats
path: root/tests/icles/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/icles/Makefile.am')
-rw-r--r--tests/icles/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/icles/Makefile.am b/tests/icles/Makefile.am
new file mode 100644
index 00000000..b04651d4
--- /dev/null
+++ b/tests/icles/Makefile.am
@@ -0,0 +1,12 @@
+if USE_X
+X_TESTS = ximagesrc_test
+
+ximagesrc_test_SOURCES = ximagesrc-test.c
+ximagesrc_test_CFLAGS = $(GST_CFLAGS)
+ximagesrc_test_LDFLAGS = $(GST_LIBS)
+else
+X_TESTS =
+endif
+
+noinst_PROGRAMS = $(X_TESTS)
+