summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b6740bc..d2235f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,9 @@ if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -Wall"
fi
+AC_ARG_WITH(lockdir, AC_HELP_STRING([--with-lockdir=LOCKDIR], [Specify a lock dir]), LOCKDIR="$withval", LOCK_DIR="/var/lock")
+AC_SUBST(LOCK_DIR)
+
AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_LN_S
@@ -93,5 +96,7 @@ fi
AM_CONDITIONAL([USE_XMLTOMAN], [test "x$xmltoman" = xyes])
+AC_MSG_NOTICE([*** Using $LOCK_DIR as lock directory ***])
+
AC_CONFIG_FILES([src/Makefile Makefile man/Makefile doc/Makefile doc/README.html])
AC_OUTPUT