summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..bf98692
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,58 @@
+# $Id$
+#
+# This file is part of libnewmail.
+#
+# libnewmail is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# libnewmail is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with libnewmail; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+lib_LTLIBRARIES = libnewmail.la
+pkglib_LTLIBRARIES = libunix.la libmaildir.la libpop3.la libimap.la
+pkginclude_HEADERS=newmail.h module.h config.h util.h
+
+bin_PROGRAMS = nmail nmail-async nm-spoolhack
+noinst_PROGRAMS = easy
+
+libnewmail_la_SOURCES = config.c util.c newmail.c newmail.h util.h config.h module.h
+libnewmail_la_LDFLAGS = -version-info 0:0:0 -export-dynamic
+libnewmail_la_INCLUDES = $(INCLTDL)
+libnewmail_la_CFLAGS = -DNM_LIBRARY_PATH="\"$(pkglibdir)\""
+libnewmail_la_LIBADD = $(LIBLTDL)
+
+libunix_la_SOURCES = unix.c newmail.h config.h util.h module.h
+libunix_la_LDFLAGS = -module
+
+libmaildir_la_SOURCES = maildir.c newmail.h config.h util.h module.h
+libmaildir_la_LDFLAGS = -module
+
+libpop3_la_SOURCES = pop3.c sockwrap.c md5.c md5.h sockwrap.h newmail.h config.h util.h module.h
+libpop3_la_LDFLAGS = -module
+libpop3_la_CFLAGS = $(LIBGNUTLS_CFLAGS)
+libpop3_la_LIBADD = $(LIBGNUTLS_LIBS)
+
+libimap_la_SOURCES = imap.c sockwrap.c md5.c md5.h sockwrap.h newmail.h config.h util.h module.h
+libimap_la_LDFLAGS = -module
+libimap_la_CFLAGS = $(LIBGNUTLS_CFLAGS)
+libimap_la_LIBADD = $(LIBGNUTLS_LIBS)
+
+nmail_SOURCES = nmail.c newmail.h
+nmail_LDADD = libnewmail.la
+
+nmail_async_SOURCES = nmail-async.c newmail.h
+nmail_async_LDADD = libnewmail.la
+
+nm_spoolhack_SOURCES = nm-spoolhack.c newmail.h
+nm_spoolhack_LDADD = libnewmail.la
+
+easy_SOURCES = easy.c newmail.h
+easy_LDADD = libnewmail.la