summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-12-06 18:28:26 +0000
committerLennart Poettering <lennart@poettering.net>2004-12-06 18:28:26 +0000
commitf983d9ab69dedcf3d707617f449f0b9497f592a1 (patch)
treee2875a7d7c4d132ae0b0bf29f8847946661424b2 /doc/Makefile.am
parentf21cfeae07e2cff02be9a26ea076001d4e4c5fd3 (diff)
add documentation
git-svn-id: file:///home/lennart/svn/public/nss-mdns/trunk@57 0ee8848e-81ea-0310-a63a-f631d1a40d77
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..752b2d6
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,36 @@
+# $Id$
+
+# This file is part of nss-mdns.
+#
+# nss-mdns is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# nss-mdns is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with nss-mdns; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+noinst_DATA = README.html README
+EXTRA_DIST = $(noinst_DATA) style.css
+
+MAINTAINERCLEANFILES = README.html
+CLEANFILES =
+
+if USE_LYNX
+README: README.html
+ lynx --dump $^ | sed 's,file://localhost/.*/doc/README.html,README,' > $@
+
+CLEANFILES += README
+endif
+
+tidy: README.html
+ tidy -qe < README.html ; true
+
+.PHONY: tidy
+