summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-04-13 17:32:10 +0000
committerLennart Poettering <lennart@poettering.net>2006-04-13 17:32:10 +0000
commit1f7a008f4331bfe21e2de6f2ec9cab997f310465 (patch)
treed5ffff801ca0f74345a55dcbde0f1e0304f92141 /configure.ac
parentdf108afe352a4f0e8d67510f923878e954714c94 (diff)
add new configure option to enable preloading even on architectures that support dlopen(). Useful for debugging
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@700 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7d7f8f73..6511137e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -398,6 +398,12 @@ if test "x$PREOPEN_MODS" != "xall" ; then
AC_SUBST(PREOPEN_MODS)
fi
+AC_ARG_ENABLE(
+ [force-preopen],
+ AC_HELP_STRING([--enable-force-preopen],[Preopen modules, even when dlopen() is supported.]),
+ [FORCE_PREOPEN=1], [FORCE_PREOPEN=0])
+AM_CONDITIONAL([FORCE_PREOPEN], [test "x$FORCE_PREOPEN" = "x1"])
+
AC_CONFIG_FILES([
Makefile
src/Makefile