summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Guthrie <cguthrie@mandriva.org>2010-05-29 19:33:54 +0100
committerColin Guthrie <cguthrie@mandriva.org>2010-08-15 21:41:52 +0100
commit2b88634671d1b745b1364e9cf4827e30a5ff2a6e (patch)
treeeb453f9e6c9eb70fb34a8483aca9ab8e72b7cb26 /configure.ac
parent4a1072e0bcce9165a262dc76a12baa2680caa0e3 (diff)
x11: Partially convert to XCB.
This commit mostly converts the X11 handling to XCB. There are still some uses of XLib to deal with the X11 session handling modules, however all client-side code should now be free of XLib and thus this should fix Bug #799
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index abcce13f..d15499c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -516,7 +516,7 @@ AC_ARG_ENABLE([x11],
[x11=auto])
if test "x${x11}" != xno ; then
- PKG_CHECK_MODULES(X11, [ x11 ice sm xtst ],
+ PKG_CHECK_MODULES(X11, [ x11-xcb ice sm xtst xcb-atom ],
HAVE_X11=1,
[
HAVE_X11=0