summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorColin Guthrie <colin@mageia.org>2011-06-07 12:18:17 +0200
committerColin Guthrie <colin@mageia.org>2011-06-22 23:12:19 +0100
commit35f99c6e31d90439f2bfbefb8b45cff323b40661 (patch)
tree3b479a58be367d5fbf015f12c74682fc31a0a28a /src/Makefile.am
parent695d5363803b7051f85bef82b55220aa37b212a5 (diff)
device-restore: Add a new protocol extension for device-restore.
This simply exposes the formats that a device supports via a simple protocol extension that will allow clients to setup what a connected receiver supports format wise.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index aa6b4452..01c2ffc0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -732,6 +732,7 @@ pulseinclude_HEADERS = \
pulse/def.h \
pulse/error.h \
pulse/ext-device-manager.h \
+ pulse/ext-device-restore.h \
pulse/ext-stream-restore.h \
pulse/format.h \
pulse/gccmacro.h \
@@ -784,6 +785,7 @@ libpulse_la_SOURCES = \
pulse/def.h \
pulse/error.c pulse/error.h \
pulse/ext-device-manager.c pulse/ext-device-manager.h \
+ pulse/ext-device-restore.c pulse/ext-device-restore.h \
pulse/ext-stream-restore.c pulse/ext-stream-restore.h \
pulse/gccmacro.h \
pulse/internal.h \
@@ -1754,9 +1756,14 @@ module_device_manager_la_CFLAGS = $(AM_CFLAGS)
# Device volume/muted restore module
module_device_restore_la_SOURCES = modules/module-device-restore.c
module_device_restore_la_LDFLAGS = $(MODULE_LDFLAGS)
-module_device_restore_la_LIBADD = $(MODULE_LIBADD)
+module_device_restore_la_LIBADD = $(MODULE_LIBADD) libprotocol-native.la
module_device_restore_la_CFLAGS = $(AM_CFLAGS)
+if HAVE_DBUS
+module_device_restore_la_LIBADD += $(DBUS_LIBS)
+module_device_restore_la_CFLAGS += $(DBUS_CFLAGS)
+endif
+
# Stream volume/muted/device restore module
module_stream_restore_la_SOURCES = modules/module-stream-restore.c
module_stream_restore_la_LDFLAGS = $(MODULE_LDFLAGS)