summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@collabora.co.uk>2010-08-23 16:38:47 +0200
committerWim Taymans <wim.taymans@collabora.co.uk>2010-08-23 16:55:23 +0200
commit3dc5469c1fba70aacf545d935f0da49df5a08bc9 (patch)
treeea2194cfed8062929cd3110e7e4577368878e201 /src/Makefile.am
parentef8abcb1b515b676508bcd25d088c23c6a34fcd6 (diff)
make echo-cancel module that exposes a new sink and source
Make a new echo-cancel module that exposes a new sink and source. All data sent to the sink is matched against the data captured from the source and echo-canceled using the speex echo canceler.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 46e6577e..df4bee8e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1013,6 +1013,7 @@ modlibexec_LTLIBRARIES += \
module-rescue-streams.la \
module-intended-roles.la \
module-suspend-on-idle.la \
+ module-echo-cancel.la \
module-http-protocol-tcp.la \
module-sine.la \
module-native-protocol-tcp.la \
@@ -1286,6 +1287,7 @@ SYMDEF_FILES = \
modules/module-rescue-streams-symdef.h \
modules/module-intended-roles-symdef.h \
modules/module-suspend-on-idle-symdef.h \
+ modules/module-echo-cancel-symdef.h \
modules/module-hal-detect-symdef.h \
modules/module-udev-detect-symdef.h \
modules/bluetooth/module-bluetooth-proximity-symdef.h \
@@ -1699,6 +1701,12 @@ module_suspend_on_idle_la_LDFLAGS = $(MODULE_LDFLAGS)
module_suspend_on_idle_la_LIBADD = $(AM_LIBADD) libpulsecore-@PA_MAJORMINORMICRO@.la libpulsecommon-@PA_MAJORMINORMICRO@.la libpulse.la
module_suspend_on_idle_la_CFLAGS = $(AM_CFLAGS)
+# echo-cancel module
+module_echo_cancel_la_SOURCES = modules/module-echo-cancel.c
+module_echo_cancel_la_LDFLAGS = $(MODULE_LDFLAGS)
+module_echo_cancel_la_LIBADD = $(AM_LIBADD) libpulsecore-@PA_MAJORMINORMICRO@.la libpulsecommon-@PA_MAJORMINORMICRO@.la libpulse.la $(LIBSPEEX_LIBS)
+module_echo_cancel_la_CFLAGS = $(AM_CFLAGS) $(LIBSPEEX_CFLAGS)
+
# RTP modules
module_rtp_send_la_SOURCES = modules/rtp/module-rtp-send.c
module_rtp_send_la_LDFLAGS = $(MODULE_LDFLAGS)