summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-11-24 16:26:49 +0000
committerLennart Poettering <lennart@poettering.net>2007-11-24 16:26:49 +0000
commit95a98fe6f2002c9dd448b70bb6944541b5616df3 (patch)
treed1626697363d0bf059273404a2c4414e704c2385 /src/Makefile.am
parent2d34bca4a13bc43eeda54535630e37703806d53f (diff)
Add new subsystem for applying envelopes (such as volume ramps) to audio signals
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@2082 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 84649c48..44f906f0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -253,7 +253,8 @@ noinst_PROGRAMS = \
resampler-test \
smoother-test \
mix-test \
- remix-test
+ remix-test \
+ envelope-test
if HAVE_SIGXCPU
noinst_PROGRAMS += \
@@ -418,6 +419,11 @@ smoother_test_LDADD = $(AM_LDADD) libpulsecore.la
smoother_test_CFLAGS = $(AM_CFLAGS)
smoother_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
+envelope_test_SOURCES = tests/envelope-test.c
+envelope_test_LDADD = $(AM_LDADD) libpulsecore.la
+envelope_test_CFLAGS = $(AM_CFLAGS) $(LIBOIL_CFLAGS)
+envelope_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS) $(LIBOIL_LIBS)
+
###################################
# Client library #
###################################
@@ -749,6 +755,7 @@ libpulsecore_la_SOURCES += \
pulsecore/once.c pulsecore/once.h \
pulsecore/time-smoother.c pulsecore/time-smoother.h \
pulsecore/start-child.c pulsecore/start-child.h \
+ pulsecore/envelope.c pulsecore/envelope.h \
$(PA_THREAD_OBJS)
if OS_IS_WIN32