summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorErich Boleyn <erich@uruk.org>2009-04-15 23:02:59 -0700
committerLennart Poettering <lennart@poettering.net>2009-04-19 02:06:33 +0200
commitb03a650160def727ff6547cdc35351d76dceecfd (patch)
treec38ba1a5ad0eb5fa9657d054cea158ea2984770f /src/Makefile.am
parent1c0667de21e183d8a3ac79bba2bc534a6f38b690 (diff)
reserve-device: allow building without D-Bus
Lennart Poettering <lennart@poettering.net> wrote: > On Wed, 15.04.09 16:26, Erich Boleyn (erich@uruk.org) wrote: > > > Just noticed the new 0.9.15 release, got it building on Gentoo, and then > > found that the non-dbus build's ALSA modules appear to be broken: ... > > Is this something that can stubbed out (relatively) safely? > > Hmm, yes. As it seems I broke the build for non-dbus builds. Should be > easy to fix. Best way is probably to make the reserver wrapper mostly > a noop if D-Bus is not available. > > Please understand that I don't really focus on making every weird > combination of build deps work. So I won't fix this for you. But I am > happy to merge good patches! No problem, I was mainly looking for a hint that to your knowledge there should be no wierd side-effects from stubbing out the reserve and dbus functions inside reserve_wrapper. Thanks for said hint. ;-) Attached is a patch to include "reserve_wrapper.[ch]" in the non-dbus builds, and do said stubbing when HAVE_DBUS is not defined. It has passed moderate testing: built both versions, both pass "pulseaudio --dump-modules" with no weird messages, and the "--disable-dbus" build works and produces audio as expected in some simple tests including RTP.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0d4f53af..716d8653 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1315,7 +1315,7 @@ module_oss_la_LIBADD = $(AM_LIBADD) liboss-util.la libpulsecore-@PA_MAJORMINORMI
# ALSA
-libalsa_util_la_SOURCES = modules/alsa/alsa-util.c modules/alsa/alsa-util.h modules/alsa/alsa-sink.c modules/alsa/alsa-sink.h modules/alsa/alsa-source.c modules/alsa/alsa-source.h
+libalsa_util_la_SOURCES = modules/alsa/alsa-util.c modules/alsa/alsa-util.h modules/alsa/alsa-sink.c modules/alsa/alsa-sink.h modules/alsa/alsa-source.c modules/alsa/alsa-source.h modules/reserve-wrap.c modules/reserve-wrap.h
libalsa_util_la_LDFLAGS = -avoid-version
libalsa_util_la_LIBADD = $(AM_LIBADD) $(ASOUNDLIB_LIBS) libpulsecore-@PA_MAJORMINORMICRO@.la libpulsecommon-@PA_MAJORMINORMICRO@.la libpulse.la
libalsa_util_la_CFLAGS = $(AM_CFLAGS) $(ASOUNDLIB_CFLAGS)
@@ -1333,7 +1333,7 @@ libalsa_util_la_CFLAGS += $(UDEV_CFLAGS)
endif
if HAVE_DBUS
-libalsa_util_la_SOURCES += modules/reserve.h modules/reserve.c modules/reserve-wrap.c modules/reserve-wrap.h
+libalsa_util_la_SOURCES += modules/reserve.h modules/reserve.c
libalsa_util_la_LIBADD += $(DBUS_LIBS)
libalsa_util_la_CFLAGS += $(DBUS_CFLAGS)
endif