summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorArun Raghavan <arun.raghavan@collabora.co.uk>2011-03-02 10:51:56 +0530
committerArun Raghavan <arun.raghavan@collabora.co.uk>2011-05-02 11:54:48 +0530
commite64f02ad9ec7d027e0360e3964e88a497d5df02f (patch)
tree70646b0590f4a3cd911d03b266b9e325c8e56dd2 /src/Makefile.am
parent71ec9577cf052558cfddb051c7d038c91b397bc5 (diff)
tests: Add a trivial test for the extended API
This is just sync-playback.c modified to use the extended API. We need something more sophisticated for properly testing the compressed formats, but that is a non-trivial task in itself.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1b8b447e..e3217043 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -274,6 +274,7 @@ TESTS_BINARIES = \
mcalign-test \
pacat-simple \
parec-simple \
+ extended-test \
strlist-test \
close-test \
voltest \
@@ -439,6 +440,11 @@ parec_simple_LDADD = $(AM_LDADD) libpulse.la libpulse-simple.la libpulsecommon-@
parec_simple_CFLAGS = $(AM_CFLAGS)
parec_simple_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
+extended_test_SOURCES = tests/extended-test.c
+extended_test_LDADD = $(AM_LDADD) libpulse.la libpulsecommon-@PA_MAJORMINOR@.la
+extended_test_CFLAGS = $(AM_CFLAGS)
+extended_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
+
strlist_test_SOURCES = tests/strlist-test.c
strlist_test_CFLAGS = $(AM_CFLAGS)
strlist_test_LDADD = $(AM_LDADD) $(WINSOCK_LIBS) libpulsecore-@PA_MAJORMINOR@.la libpulse.la libpulsecommon-@PA_MAJORMINOR@.la