summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMaarten Bosmans <mkbosmans@gmail.com>2011-02-17 11:28:54 +0100
committerMaarten Bosmans <mkbosmans@gmail.com>2011-02-17 12:02:31 +0100
commitf2a9fd779e6bfc79d7e6f6f45447e9adbb873c34 (patch)
tree81d6bb087c4e6fabc2f0bb749d70bee727a5defb /src/Makefile.am
parent110b14ec21eacaf6baa4fa111a76e26bad585dcd (diff)
Give module-waveout a configure switch
- Also disable the scary DBus and udev warnings when building for win32 - and only install some dbus/x11 specific files when appropriate
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ed4a06a1..d49d91c7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -112,8 +112,10 @@ pulseconf_DATA = \
daemon.conf \
client.conf
+if HAVE_DBUS
dbuspolicy_DATA = \
daemon/pulseaudio-system.conf
+endif
if HAVE_X11
xdgautostart_in_files = \
@@ -175,6 +177,8 @@ endif
# Utility programs #
###################################
+bin_SCRIPTS = esdcompat
+
bin_PROGRAMS += \
pacat \
pactl
@@ -189,14 +193,13 @@ endif
if HAVE_X11
bin_PROGRAMS += pax11publish
+bin_SCRIPTS += start-pulseaudio-x11 start-pulseaudio-kde
endif
if HAVE_AVAHI
bin_PROGRAMS += pabrowse
endif
-bin_SCRIPTS = esdcompat start-pulseaudio-x11 start-pulseaudio-kde
-
pacat_SOURCES = utils/pacat.c
pacat_LDADD = $(AM_LDADD) libpulse.la libpulsecommon-@PA_MAJORMINOR@.la $(LIBSNDFILE_LIBS)
pacat_CFLAGS = $(AM_CFLAGS) $(LIBSNDFILE_CFLAGS)
@@ -1183,7 +1186,7 @@ pulselibexec_PROGRAMS += \
gconf-helper
endif
-if OS_IS_WIN32
+if HAVE_WAVEOUT
modlibexec_LTLIBRARIES += \
module-waveout.la
endif