summaryrefslogtreecommitdiffstats
path: root/schemas/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'schemas/Makefile.am')
-rw-r--r--schemas/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/schemas/Makefile.am b/schemas/Makefile.am
index aae3947..dffc000 100644
--- a/schemas/Makefile.am
+++ b/schemas/Makefile.am
@@ -1,12 +1,12 @@
-SCHEMAS_FILE = service-discovery-applet.schemas
-
-EXTRA_DIST = $(SCHEMAS_FILE)
+EXTRA_DIST = $(schemas_in_files)
schemasdir = $(GCONF_SCHEMA_FILE_DIR)
-schemas_DATA = $(SCHEMAS_FILE)
+schemas_in_files = service-discovery-applet.schemas.in
+schemas_DATA = $(schemas_in_files:.schemas.in=.schemas)
+@INTLTOOL_SCHEMAS_RULE@
install-schemas:
- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) gconftool-2 --makefile-install-rule $(top_srcdir)/schemas/$(SCHEMAS_FILE) 2>&1 > /dev/null
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) gconftool-2 --makefile-install-rule $(top_srcdir)/schemas/$(schemas_DATA) 2>&1 > /dev/null
gconftool-2 --shutdown
if GCONF_SCHEMAS_INSTALL