summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Jon McCann <mccann@jhu.edu>2007-03-01 14:24:27 -0500
committerWilliam Jon McCann <mccann@jhu.edu>2007-03-01 14:24:27 -0500
commit1d1b98cd17764be77b1aee79efae8e89ce7faa04 (patch)
treea7cb12bfcbf9061b26c9d274781d00361f4667fd /configure.ac
parente37a78dfc5abcb3b02cb5debaa24122fa9b949c4 (diff)
add a test program for the PAM module
Basically this is a mini login. It authenticates, opens a session, sleeps 20 seconds, and then closes the session.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1e2c1aa..4b8f8ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,7 +206,11 @@ fi
have_pam=no
AC_CHECK_LIB(pam, pam_getenv, have_pam=yes)
AM_CONDITIONAL(HAVE_PAM, test x$have_pam = xyes)
+if test "x$have_pam" = "xyes"; then
+ PAM_LIBS="${PAM_LIBS} -lpam"
+fi
AC_SUBST(HAVE_PAM)
+AC_SUBST(PAM_LIBS)
#
# Check if we should build the PAM module