summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1e2c1aa..4b8f8ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,7 +206,11 @@ fi
have_pam=no
AC_CHECK_LIB(pam, pam_getenv, have_pam=yes)
AM_CONDITIONAL(HAVE_PAM, test x$have_pam = xyes)
+if test "x$have_pam" = "xyes"; then
+ PAM_LIBS="${PAM_LIBS} -lpam"
+fi
AC_SUBST(HAVE_PAM)
+AC_SUBST(PAM_LIBS)
#
# Check if we should build the PAM module