summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Knowles <alan@akkbhome.com>2010-06-27 02:55:13 +0200
committerLennart Poettering <lennart@poettering.net>2010-06-27 03:00:59 +0200
commit4ded79d54dd514c7f7d711e38ec4277f4427c78e (patch)
tree6c495ab96535f2907f031500520798fd667346cf /configure.ac
parented11c6a4d4da379ff9ebccb7a0340e64232efabb (diff)
gobject: implement gobject introspection
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 42d7d22..1be1f60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,7 @@
AC_PREREQ(2.63)
AC_INIT([avahi],[0.6.25],[avahi (at) lists (dot) freedesktop (dot) org])
AC_CONFIG_SRCDIR([avahi-core/server.c])
+AC_CONFIG_MACRO_DIR([common])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign 1.11 -Wall -Wno-portability silent-rules tar-pax])
@@ -469,6 +470,11 @@ fi
AM_CONDITIONAL(HAVE_GOBJECT, test "x$HAVE_GOBJECT" = "xyes")
#
+# Introspection support.
+#
+GOBJECT_INTROSPECTION_CHECK([0.6.7])
+
+#
# Check for Qt 3
#
AC_ARG_ENABLE(qt3,
@@ -1136,6 +1142,7 @@ echo "
CFLAGS: ${CFLAGS}
Enable GLIB: ${HAVE_GLIB}
Enable GLIB GObject: ${HAVE_GOBJECT}
+ Enable GObject Introspection: ${found_introspection}
Enable GTK 2.0: ${HAVE_GTK}
Enable GTK 3.0: ${HAVE_GTK3}
Enable D-Bus: ${HAVE_DBUS}