summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2006-11-13 07:17:40 +0000
committerMarcel Holtmann <marcel@holtmann.org>2006-11-13 07:17:40 +0000
commit150f9b6873e4ec8473194bdfdc0b05b4d0d37158 (patch)
tree7291856e24cc85e43833715cd29497d3eb8b419b /common/Makefile.am
parent6f9503c6dd849b1cb21bd4e17acf079e2e546b06 (diff)
Add Expat library check and dummy skeleton
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 1203652a..182d574e 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -1,10 +1,16 @@
+if EXPAT
+sdp_sources = sdp-expat.c
+else
+sdp_sources = sdp-dummy.c
+endif
+
noinst_LIBRARIES = libhelper.a
libhelper_a_SOURCES = oui.h oui.c list.h list.c \
textfile.h textfile.c helper.h helper.c \
glib-ectomy.h glib-ectomy.c logging.h logging.c \
- dbus.h dbus.c sdp-xml.h sdp-xml.c sdp-expat.c
+ dbus.h dbus.c sdp-xml.h sdp-xml.c $(sdp_sources)
noinst_PROGRAMS = test_textfile
@@ -12,6 +18,6 @@ test_textfile_LDADD = libhelper.a
AM_CFLAGS = @DBUS_CFLAGS@
-EXTRA_DIST = ppoll.h
+EXTRA_DIST = ppoll.h sdp-dummy.c sdp-expat.c
MAINTAINERCLEANFILES = Makefile.in