summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 1203652a..182d574e 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -1,10 +1,16 @@
+if EXPAT
+sdp_sources = sdp-expat.c
+else
+sdp_sources = sdp-dummy.c
+endif
+
noinst_LIBRARIES = libhelper.a
libhelper_a_SOURCES = oui.h oui.c list.h list.c \
textfile.h textfile.c helper.h helper.c \
glib-ectomy.h glib-ectomy.c logging.h logging.c \
- dbus.h dbus.c sdp-xml.h sdp-xml.c sdp-expat.c
+ dbus.h dbus.c sdp-xml.h sdp-xml.c $(sdp_sources)
noinst_PROGRAMS = test_textfile
@@ -12,6 +18,6 @@ test_textfile_LDADD = libhelper.a
AM_CFLAGS = @DBUS_CFLAGS@
-EXTRA_DIST = ppoll.h
+EXTRA_DIST = ppoll.h sdp-dummy.c sdp-expat.c
MAINTAINERCLEANFILES = Makefile.in