summaryrefslogtreecommitdiffstats
path: root/serial/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'serial/Makefile.am')
-rw-r--r--serial/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/serial/Makefile.am b/serial/Makefile.am
index 02742923..7cb86842 100644
--- a/serial/Makefile.am
+++ b/serial/Makefile.am
@@ -1,2 +1,13 @@
+noinst_PROGRAMS = bluetoothd-service-serial
+
+bluetoothd_service_serial_SOURCES = main.c
+
+LDADD = $(top_builddir)/common/libhelper.a \
+ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
+
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@
+
+INCLUDES = -I$(top_srcdir)/common
+
MAINTAINERCLEANFILES = Makefile.in