summaryrefslogtreecommitdiffstats
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-08-08 21:30:31 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2006-08-08 21:30:31 +0000
commitaaa432b0644199418eb2ce506c87397cd379df4f (patch)
treeab3c01fd243dbf8c74134160a7737d50cc1f1402 /bus/Makefile.am
parentd33564292f0cb45c42454514797c6da1fc1de178 (diff)
* configure.in:
* tools/Makefile.am: * tools/dbus-launch.c: * bus/Makefile.am: allow --with-dbus-daemondir switch to be used to make the daemon install to a seperate bindir like /usr/libexec (patch from Brian Cameron <brian dot cameron at sun dot com)
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index 9815bfd8..89bb523c 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -16,8 +16,6 @@ config_DATA= \
session.conf \
system.conf
-bin_PROGRAMS=dbus-daemon
-
if DBUS_USE_LIBXML
XML_SOURCES=config-loader-libxml.c
endif
@@ -79,7 +77,7 @@ endif
## we use noinst_PROGRAMS not check_PROGRAMS so that we build
## even when not doing "make check"
-noinst_PROGRAMS=$(TESTS)
+noinst_PROGRAMS=$(TESTS) dbus-daemon
bus_test_SOURCES= \
$(BUS_SOURCES) \
@@ -91,7 +89,15 @@ bus_test_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_BUS_LIBS)
clean-local:
/bin/rm *.bb *.bbg *.da *.gcov || true
+uninstall-hook:
+ rm -f $(DESTDIR)$(DBUS_DAEMONDIR)/dbus-daemon
+
install-data-hook:
+ if test '!' -d $(DESTDIR)$(DBUS_DAEMONDIR); then \
+ $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \
+ chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
+ fi
+ $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
$(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
$(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
$(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services