summaryrefslogtreecommitdiffstats
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-08-08 22:08:39 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2006-08-08 22:08:39 +0000
commitd387411488a093f77f4cd752b75e8bf8360550c6 (patch)
tree105785190be1d6a0667a861bba4c52794e9891f2 /bus/Makefile.am
parentaaa432b0644199418eb2ce506c87397cd379df4f (diff)
* dbus/dbus-sysdeps.h:
* dbus/dbus-sysdeps.c: * dbus/dbus-string.c: s/_dbus_printf_length/_dbus_printf_string_upper_bound to comform with GLib's function which does the same thing * configure.in: * bus/Makefile.am: * bus/dir-watch-default.c: * bus/dir-watch-dnotify.c: * bus/dir-watch-kqueue.c: Add kqueue directory watching for freebsd and split the directory watching code into seperate files per method/arch (patches from Timothy Redaelli <drizzt at gufi dotorg>)
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index 89bb523c..575274a8 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -23,6 +23,16 @@ if DBUS_USE_EXPAT
XML_SOURCES=config-loader-expat.c
endif
+if DBUS_BUS_ENABLE_KQUEUE_ON_FREEBSD
+DIR_WATCH_SOURCE=dir-watch-kqueue.c
+else
+if DBUS_BUS_ENABLE_DNOTIFY_ON_LINUX
+DIR_WATCH_SOURCE=dir-watch-dnotify.c
+else
+DIR_WATCH_SOURCE=dir-watch-default.c
+endif
+endif
+
BUS_SOURCES= \
activation.c \
activation.h \
@@ -34,7 +44,7 @@ BUS_SOURCES= \
connection.h \
desktop-file.c \
desktop-file.h \
- dir-watch.c \
+ $(DIR_WATCH_SOURCE) \
dir-watch.h \
dispatch.c \
dispatch.h \