summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-08-04 16:15:16 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2006-08-04 16:15:16 +0000
commit222bd07e9df5e3b5a367d1282b43fd3a827a7552 (patch)
tree49b0338a6251ebf98649dfec9efef2ccd64c1ed5 /configure.in
parent7652304bff969afb3969603149bb385efe861fe8 (diff)
* configure.in: add -Wdeclaration-after-statement
* dbus/dbus-connection.c: change all the pending call stuff to reflect the fact that pending call operations use the connection lock * dbus/dbus-pending-call.c: add locking here * dbus/dbus-errors.c (struct DBusRealError): don't make the name field const consistent with how message field is done
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 65736a89..dfad86ed 100644
--- a/configure.in
+++ b/configure.in
@@ -138,6 +138,11 @@ if test "x$GCC" = "xyes"; then
*) CFLAGS="$CFLAGS -Wsign-compare" ;;
esac
+ case " $CFLAGS " in
+ *[\ \ ]-Wdeclaration-after-statement[\ \ ]*) ;;
+ *) CFLAGS="$CFLAGS -Wdeclaration-after-statement" ;;
+ esac
+
if test "x$enable_ansi" = "xyes"; then
case " $CFLAGS " in
*[\ \ ]-ansi[\ \ ]*) ;;