summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-10-14 17:38:56 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2006-10-14 17:38:56 +0000
commit3026a5ed19ac27fd42f90cc57ed305bd2a296e6a (patch)
tree21b12917d76578fd0dee0e370406cac609a1f3b4 /configure.in
parent2dd42bd7f5651309ad727ef5c0b215fbda76fa5d (diff)
* configure.in: Released 1.0 RC 2(0.94)dbus-0.94
Add check for -fPIC and enable it if available
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 53ecf3d8..f8856a17 100644
--- a/configure.in
+++ b/configure.in
@@ -5,7 +5,7 @@ AC_INIT(dbus/dbus.h)
AC_CANONICAL_TARGET
-AM_INIT_AUTOMAKE(dbus, 0.93.1)
+AM_INIT_AUTOMAKE(dbus, 0.94)
AM_CONFIG_HEADER(config.h)
@@ -187,6 +187,14 @@ if test "x$GCC" = "xyes"; then
;;
esac
+ case " $CFLAGS " in
+ *[\ \ ]-fPIC[\ \ ]*) ;;
+ *) if cc_supports_flag -fPIC; then
+ CFLAGS="$CFLAGS -fPIC"
+ fi
+ ;;
+ esac
+
if test "x$enable_ansi" = "xyes"; then
case " $CFLAGS " in
*[\ \ ]-ansi[\ \ ]*) ;;