summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-05 10:04:04 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-05 10:04:04 +0000
commit3a96e4ffd99ec3f125e1891155ecb751b6e313a1 (patch)
treef64f075a2100392883429e9aaa467be26a001669 /test/Makefile.am
parent03b9ca6d4ecf2577958530b8390d675c73a58825 (diff)
2003-04-05 Havoc Pennington <hp@pobox.com>
* Makefile.am (coverage-report.txt): add target "coverage-report.txt" * test/decode-gcov.c: hack up a little program to suck data out of gcov files. Yes this is sort of silly. * configure.in: define something in config.h and do an AM_CONDITIONAL when gcov is enabled
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index c46b2797..ddbe69c4 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -7,7 +7,13 @@ else
TEST_BINARIES=
endif
-noinst_PROGRAMS= $(TEST_BINARIES)
+if DBUS_GCOV_ENABLED
+GCOV_BINARIES=decode-gcov
+else
+GCOV_BINARIES=
+endif
+
+noinst_PROGRAMS= $(TEST_BINARIES) $(GCOV_BINARIES)
echo_client_SOURCES= \
echo-client.c \
@@ -49,6 +55,9 @@ test_segfault_SOURCES = \
test_sleep_forever_SOURCES = \
test-sleep-forever.c
+decode_gcov_SOURCES= \
+ decode-gcov.c
+
TEST_LIBS=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la
echo_client_LDADD=$(TEST_LIBS)
@@ -58,6 +67,7 @@ unbase64_LDADD=$(TEST_LIBS)
break_loader_LDADD= $(TEST_LIBS)
#bus_test_LDADD=$(TEST_LIBS) $(top_builddir)/bus/libdbus-daemon.la
spawn_test_LDADD=$(TEST_LIBS)
+decode_gcov_LDADD=$(TEST_LIBS)
EXTRA_DIST=