summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2004-06-24 01:43:54 +0000
committerBenjamin Otte <otte@gnome.org>2004-06-24 01:43:54 +0000
commit4eb2d088afb94d2fb623a5b307ec5471d2559873 (patch)
treeb01e8cdb546515f8a00f993bfe0ee713b8ebd43e /Makefile.am
parentbfaca2b9b77c9ba932581e5981ec7cc703da4828 (diff)
don't include -enumtypes.[ch] or -marshal.[ch] files in the disted tarball.
Original commit message from CVS: * gst-libs/gst/colorbalance/Makefile.am: * gst-libs/gst/mixer/Makefile.am: * gst-libs/gst/play/Makefile.am: * gst-libs/gst/tuner/Makefile.am: * gst/tcp/Makefile.am: * sys/dxr3/Makefile.am: don't include -enumtypes.[ch] or -marshal.[ch] files in the disted tarball. Also add all *.list files that were missing. * Makefile.am: add a distcheck hook to ensure the above doesn't happen again.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 258a79c8..d773bc68 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,5 +44,13 @@ EXTRA_DIST=gst-plugins.spec depcomp \
DISTCLEANFILES=_stdint.h
+# check that no marshal or enumtypes files are included
+# this in turn ensures that distcheck fails for missing .list files which is currently
+# shadowed when the corresponding .c and .h files are included.
+distcheck-hook:
+ test "x" = "x`find $(distdir) -name \*-enumtypes.[ch]`" && \
+ test "x" = "x`find $(distdir) -name \*-marshal.[ch]`" || \
+ ( $(ECHO) "*** Still leftover enumtypes or marshal files in the tarball. Please make sure those are not disted." && false )
+
include $(top_srcdir)/common/release.mak
include $(top_srcdir)/common/po.mak