summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 258a79c8..d773bc68 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,5 +44,13 @@ EXTRA_DIST=gst-plugins.spec depcomp \
DISTCLEANFILES=_stdint.h
+# check that no marshal or enumtypes files are included
+# this in turn ensures that distcheck fails for missing .list files which is currently
+# shadowed when the corresponding .c and .h files are included.
+distcheck-hook:
+ test "x" = "x`find $(distdir) -name \*-enumtypes.[ch]`" && \
+ test "x" = "x`find $(distdir) -name \*-marshal.[ch]`" || \
+ ( $(ECHO) "*** Still leftover enumtypes or marshal files in the tarball. Please make sure those are not disted." && false )
+
include $(top_srcdir)/common/release.mak
include $(top_srcdir)/common/po.mak