summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2009-02-25 20:47:15 -0800
committerDavid Schleef <ds@schleef.org>2009-02-25 20:47:15 -0800
commit80510aeee70ca73d3102559ce9a919134ce9629e (patch)
tree4d35f11304a672405a06671b7f6de50d68583cd8 /Makefile.am
parentb264c990747bbe837caf89bad1b6c4924750e9fd (diff)
Change how win32/common/config.h is updated
Generate win32/common/config.h-new directly from config.h.in, using shell variables in configure and some hard-coded information. Change top-level makefile so that 'make win32-update' copies the generated file to win32/common/config.h, which we keep in source control. It's kept in source control so that the git tree is buildable from VS. This change is similar to the one recently applied to GStreamer and gst-plugins-good. The previous config.h file in -good was in pretty bad shape, so unlike core and base, I didn't attempt to leave it strictly the same, but fixed it as necessary. Needs testing I cannot do myself.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 46c6f5bb..4247a971 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,5 +55,9 @@ check-torture:
true
endif
+win32-update:
+ cp $(top_builddir)/win32/common/config.h-new \
+ $(top_srcdir)/win32/common/config.h
+
include $(top_srcdir)/common/coverage/lcov.mak