summaryrefslogtreecommitdiffstats
path: root/sys/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2001-12-20 21:03:18 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2001-12-20 21:03:18 +0000
commit12e4f309b211e0e0395f862eeb9dce424b3e0c5c (patch)
tree45cfe93541f2dda147089effbe3eee11606f7706 /sys/Makefile.am
parentb6b5c5a3fd81b63b74a6aaa97b0aa57a3f90ef27 (diff)
added qcam checks
Original commit message from CVS: added qcam checks
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index 256abfe7..2054a4a1 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -5,6 +5,12 @@ else
OSS_SUBDS=
endif
+if USE_QCAM
+QCAM_SUBDS=qcam
+else
+QCAM_SUBDS=
+endif
+
if USE_V4L
V4L_SUBDS=v4l
else
@@ -23,7 +29,14 @@ else
VGA_SUBDS=
endif
-SUBDIRS=$(OSS_SUBDS) qcam $(V4L_SUBDS) $(VCD_SUBDS) $(VGA_SUBDS) xvideo
+if USE_XVIDEO
+XVIDEO_SUBDS=xvideo
+else
+XVIDEO_SUBDS=
+endif
+
+SUBDIRS=$(OSS_SUBDS) $(QCAM_SUBDS) $(V4L_SUBDS) $(VCD_SUBDS) \
+ $(VGA_SUBDS) $(XVIDEO_SUBDS)
DIST_SUBDIRS=oss qcam v4l vcd vga xvideo