summaryrefslogtreecommitdiffstats
path: root/sys/oss/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2005-08-23 13:26:21 +0000
committerAndy Wingo <wingo@pobox.com>2005-08-23 13:26:21 +0000
commitd1d21600f86907f1dbd1fe4204be443eeda6cafc (patch)
tree52725fea0103ecd999811dd30868043a768640d8 /sys/oss/Makefile.am
parentffaaa7528a2348853c1a89963646012f2edba310 (diff)
sys/oss/gstossmixer.*: Refactored to be more like alsamixer.
Original commit message from CVS: 2005-08-23 Andy Wingo <wingo@pobox.com> * sys/oss/gstossmixer.h: * sys/oss/gstossmixer.c: Refactored to be more like alsamixer. * sys/oss/gstossmixertrack.h: * sys/oss/gstossmixertrack.c: Split out from gstossmixer.[ch], like gstalsamixer. * sys/oss/gstosssrc.c: * sys/oss/gstosssink.c: Where before we used a gstosselement object as a helper library, now just call functions from gstosshelper. * sys/oss/gstosshelper.h: * sys/oss/gstosshelper.c: Made a real library. Removed propertyprobe for now, should add it back later. * sys/oss/gstosselement.h: * sys/oss/gstosselement.c: Removed, we don't have a shared base class. * sys/oss/gstosshelper.c (gst_oss_helper_probe_caps): Search higher-to-lower, makes 16 bit appear earlier in the caps, which makes it preferred.
Diffstat (limited to 'sys/oss/Makefile.am')
-rw-r--r--sys/oss/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys/oss/Makefile.am b/sys/oss/Makefile.am
index d298b7ce..d4fc2394 100644
--- a/sys/oss/Makefile.am
+++ b/sys/oss/Makefile.am
@@ -1,9 +1,9 @@
plugin_LTLIBRARIES = libgstossaudio.la
libgstossaudio_la_SOURCES = gstossaudio.c \
- gstosselement.c \
gstosshelper.c \
gstossmixer.c \
+ gstossmixertrack.c \
gstosssink.c \
gstosssrc.c
@@ -17,10 +17,10 @@ libgstossaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstosssink.h \
gstosssrc.h \
- gstosselement.h \
gstosshelper.h \
gstossdmabuffer.h \
- gstossmixer.h
+ gstossmixer.h \
+ gstossmixertrack.h
# noinst_PROGRAMS = #oss_probe