summaryrefslogtreecommitdiffstats
path: root/sys/osxaudio/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2005-09-23 04:23:00 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2005-09-23 04:23:00 +0000
commit7593b38a57f55c28cdb4b8c3df27a13c6ce55d99 (patch)
tree13d564ed48fa161cc87f9dffaf6efa4152aa3dab /sys/osxaudio/Makefile.am
parent50bdf8c4623926eadd834e463357077bba0eec90 (diff)
fix build and use of GST_LIBS
Original commit message from CVS: fix build and use of GST_LIBS
Diffstat (limited to 'sys/osxaudio/Makefile.am')
-rw-r--r--sys/osxaudio/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys/osxaudio/Makefile.am b/sys/osxaudio/Makefile.am
index 0b65f38f..0744f450 100644
--- a/sys/osxaudio/Makefile.am
+++ b/sys/osxaudio/Makefile.am
@@ -1,12 +1,13 @@
plugin_LTLIBRARIES = libgstosxaudio.la
-libgstosxaudio_la_SOURCES = gstosxaudio.c \
+libgstosxaudio_la_SOURCES = gstosxaudio.c \
gstosxaudioelement.c \
gstosxaudiosink.c \
gstosxaudiosrc.c
+# FIXME: clean up these linker flags
libgstosxaudio_la_CFLAGS = $(GST_CFLAGS)
-libgstosxaudio_la_LIBADD = $(top_builddir)/gst-libs/gst/libgstinterfaces-@GST_MAJORMINOR@.la
+libgstosxaudio_la_LIBADD = $(top_builddir)/gst-libs/gst/libgstinterfaces-@GST_MAJORMINOR@.la $(GST_LIBS)
LIBS = -Wl,-framework -Wl,CoreAudio
libgstosxaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -framework CoreAudio