summaryrefslogtreecommitdiffstats
path: root/sys/osxaudio/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/osxaudio/Makefile.am')
-rw-r--r--sys/osxaudio/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys/osxaudio/Makefile.am b/sys/osxaudio/Makefile.am
index 0b65f38f..0744f450 100644
--- a/sys/osxaudio/Makefile.am
+++ b/sys/osxaudio/Makefile.am
@@ -1,12 +1,13 @@
plugin_LTLIBRARIES = libgstosxaudio.la
-libgstosxaudio_la_SOURCES = gstosxaudio.c \
+libgstosxaudio_la_SOURCES = gstosxaudio.c \
gstosxaudioelement.c \
gstosxaudiosink.c \
gstosxaudiosrc.c
+# FIXME: clean up these linker flags
libgstosxaudio_la_CFLAGS = $(GST_CFLAGS)
-libgstosxaudio_la_LIBADD = $(top_builddir)/gst-libs/gst/libgstinterfaces-@GST_MAJORMINOR@.la
+libgstosxaudio_la_LIBADD = $(top_builddir)/gst-libs/gst/libgstinterfaces-@GST_MAJORMINOR@.la $(GST_LIBS)
LIBS = -Wl,-framework -Wl,CoreAudio
libgstosxaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -framework CoreAudio