summaryrefslogtreecommitdiffstats
path: root/sys/osxaudio/Makefile.am
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerabbas@merali.org>2006-04-28 14:55:20 +0000
committerZaheer Abbas Merali <zaheerabbas@merali.org>2006-04-28 14:55:20 +0000
commit9f12811bb2272b72b1f03afaa1d97182fbf45618 (patch)
tree11298ecf9cd233e5078128e4ea6274944b7107e7 /sys/osxaudio/Makefile.am
parent4c49dc04f200450af32913ada3be9fa7c8c03a2f (diff)
sys/osxaudio/gstosxaudiosink.c: Register osxaudiosrc to the plugin.
Original commit message from CVS: 2006-04-28 Zaheer Abbas Merali <zaheerabbas at merali dot org> * sys/osxaudio/gstosxaudiosink.c: (plugin_init): Register osxaudiosrc to the plugin. * sys/osxaudio/gstosxaudiosrc.c: (gst_osx_audio_src_osxelement_do_init), (gst_osx_audio_src_base_init), (gst_osx_audio_src_class_init), (gst_osx_audio_src_init), (gst_osx_audio_src_set_property), (gst_osx_audio_src_get_property), (gst_osx_audio_src_create_ringbuffer), (gst_osx_audio_src_io_proc), (gst_osx_audio_src_osxelement_init): * sys/osxaudio/gstosxaudiosrc.h: Port of osxaudiosrc to 0.10. * sys/osxaudio/Makefile.am: Add osxaudiosrc
Diffstat (limited to 'sys/osxaudio/Makefile.am')
-rw-r--r--sys/osxaudio/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys/osxaudio/Makefile.am b/sys/osxaudio/Makefile.am
index 5f34489f..58a19dc1 100644
--- a/sys/osxaudio/Makefile.am
+++ b/sys/osxaudio/Makefile.am
@@ -2,7 +2,8 @@ plugin_LTLIBRARIES = libgstosxaudio.la
libgstosxaudio_la_SOURCES = gstosxringbuffer.c \
gstosxaudioelement.c \
- gstosxaudiosink.c
+ gstosxaudiosink.c \
+ gstosxaudiosrc.c
libgstosxaudio_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(GSTPB_BASE_FLAGS)
libgstosxaudio_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(GSTPB_BASE_LIBS) -lgstaudio-@GST_MAJORMINOR@
@@ -10,7 +11,8 @@ libgstosxaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -Wl,-framework -Wl,CoreAudio
noinst_HEADERS = gstosxaudiosink.h \
gstosxaudioelement.h \
- gstosxringbuffer.h
+ gstosxringbuffer.h \
+ gstosxaudiosrc.h