summaryrefslogtreecommitdiffstats
path: root/ext/dv/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/dv/Makefile.am')
-rw-r--r--ext/dv/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/dv/Makefile.am b/ext/dv/Makefile.am
index 5b90bf5a..9801ac0f 100644
--- a/ext/dv/Makefile.am
+++ b/ext/dv/Makefile.am
@@ -8,4 +8,12 @@ libgstdvdec_la_CFLAGS = $(GST_CFLAGS)
noinst_HEADERS = gstdvdec.h
+if HAVE_GTK
+noinst_PROGRAMS = demo-play
+endif
+
+demo_play_SOURCES = demo-play.c
+demo_play_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS)
+demo_play_LDFLAGS = $(GST_LIBS) $(GTK_LIBS)
+
EXTRA_DIST = NOTES