summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-01-07 21:17:18 +0000
committerLennart Poettering <lennart@poettering.net>2005-01-07 21:17:18 +0000
commit88de69e80f77a8ad79a1a03534b346f1a8d48ed6 (patch)
tree3885cfdb9cb7d47c8c902082334ccd599800e764 /configure.ac
parent6e7b4e60d5cbbc34b99b6a4cb3e22d061e1843a7 (diff)
* Solaris 2.8 compat
* C++ compat git-svn-id: file:///home/lennart/svn/public/libasyncns/trunk@11 cc0fb855-19ed-0310-866e-8c1d96e4abae
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4eb0200..581c086 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,6 +63,9 @@ AC_FUNC_SELECT_ARGTYPES
AC_TYPE_SIGNAL
AC_CHECK_FUNCS([memset select strndup setresuid setreuid])
+AC_CHECK_LIB(nsl, gethostbyname)
+AC_CHECK_LIB(socket, connect)
+
# If using GCC specify some additional parameters
if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -W -Wall -pedantic"