summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2006-03-29 11:27:14 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2006-03-29 11:27:14 +0000
commit02484b644e3bb6c52cb4949052992f9b96cff04e (patch)
treed33850271f672035f3f21e40910676281382e970 /Makefile.am
parentd4e37f8e60fb0105b0e9dd4ddb30428343d3e221 (diff)
fix compilation with --disable-lynx
git-svn-id: file:///home/lennart/svn/public/mod_mime_xattr/trunk@31 f01872de-66d6-0310-9185-fc3b30f50adc
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 609829e..bedd5ae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,17 +14,24 @@
# implied. See the License for the specific language governing
# permissions and limitations under the License.
-EXTRA_DIST=bootstrap.sh README LICENSE src/mod_mime_xattr.c src/Makefile.in
+EXTRA_DIST=bootstrap.sh LICENSE src/mod_mime_xattr.c src/Makefile.in
SUBDIRS=src doc
-MAINTAINERCLEANFILES = README
-noinst_DATA = README LICENSE
+MAINTAINERCLEANFILES =
+noinst_DATA = LICENSE
+
+if USE_LYNX
+EXTRA_DIST += README
+MAINTAINERCLEANFILES += README
+noinst_DATA += README
README:
rm -f README
$(MAKE) -C doc README
cd $(srcdir) && ln -s doc/README README
+endif
+
homepage: all dist
test -d $$HOME/homepage/private
mkdir -p $$HOME/homepage/private/projects/mod_mime_xattr