summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2006-03-29 11:27:14 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2006-03-29 11:27:14 +0000
commit02484b644e3bb6c52cb4949052992f9b96cff04e (patch)
treed33850271f672035f3f21e40910676281382e970 /doc/Makefile.am
parentd4e37f8e60fb0105b0e9dd4ddb30428343d3e221 (diff)
fix compilation with --disable-lynx
git-svn-id: file:///home/lennart/svn/public/mod_mime_xattr/trunk@31 f01872de-66d6-0310-9185-fc3b30f50adc
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 50afd4f..7923279 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -14,17 +14,19 @@
# implied. See the License for the specific language governing
# permissions and limitations under the License.
-noinst_DATA = README.html README
-EXTRA_DIST = $(noinst_DATA) style.css README.html.in
+noinst_DATA = README.html
-MAINTAINERCLEANFILES = README README.html
+MAINTAINERCLEANFILES = README.html
CLEANFILES =
if USE_LYNX
+noinst_DATA += README
+MAINTAINERCLEANFILES += README
+CLEANFILES += README
+
README: README.html
lynx --dump $^ | sed 's,file://localhost/.*/doc/README.html,README,' > $@
-CLEANFILES += README
endif
tidy: README.html
@@ -32,3 +34,5 @@ tidy: README.html
.PHONY: tidy
+EXTRA_DIST = $(noinst_DATA) style.css README.html.in
+